GPS track recording interrupts on Samsung A5 (2019) with Android 8

Boris shared this problem 2 years ago
Not a Problem

Hello Locus-community,


I'm new to this forum but using Locus since years - without any issues - until now. Thanks for this graet App!


My new Samsung A5 (2017) interrupts GPS track recording with Locus There are some points recorded, then there is a long pause, then there might be som more points. I cannot find a system behind it.

I switched off energy management and put Locus on th list of non-optimized Apps.

I also contacted Samsung and I am very angry about their 'support' telling me simply, the App causes the rouble.

Locus workes fine on my Galaxy Tab 10.1 and did work fin on my S5 mini. Samsung tells me, the App (Locus) would have troubles with Android 8. I doubt...

Are there any experiences with that? How to handle??

Thanks,


Boris

Comments (22)

photo
1

Hi Boris,

we discuss this problem in our team and unfortunately, no one has a clear idea, what may cause this problem. We've prepared a special test version for you here: https://drive.google.com/file/d/1AWWCKKv6jkap-5nD5m39t8lLPKvjUPLH/view?usp=sharing . This version works as Locus Map Free, but prints various test messages into Locus/logs directory. So please try this version and if the same problem appears, close app at this moment and send us here log files found in mentioned Locus/logs directory. I'm anyway worried that this won't help, but at least we may try it. Thank you!

photo
2

Hej Michal,


thank you for your quick answer!

I installed the test version (with a little fear concerning co-existence with the pro-version, but I made a backup).

Later, I will reproduce the problem and send you the logs.

Thanks,

Boris

photo
1

Hej Michal,

this is both sad and good: The test version created a track without problem!

Mmmhhh.... OK, it was quite a short track and it was with "walking" as

resolution.

I will go on and try to reproduce the prob.


Boris

photo
photo
1

Hej Michal,


here we go: Attached there is a gpx file and a coresponding log file.

What did I do? With the test-version of Locus running and tracking, I went out from harbour with the boat an put out the anchor to have a refreshing bath. After some time I left the place and went home.

Remarkable in the track is, that during the time of anchoring there are only few points recorded. I thought, a tracking was made by recording a point every 5 seconds or so. With that, it seems there are points recorded whenever there is a change of position... ??

Thanks,

Boris

<trkpt lat="54.437126" lon="10.179458">

<ele>3.55</ele>

<time>2018-07-24T13:35:17.000Z</time>

<pdop>4.00</pdop>

<extensions>

<gpxtpx:TrackPointExtension>

<gpxtpx:course>294.4</gpxtpx:course>

</gpxtpx:TrackPointExtension>

</extensions>

</trkpt>

<trkpt lat="54.437037" lon="10.179398">

<ele>6.55</ele>

<time>2018-07-24T14:08:49.000Z</time>

<pdop>4.00</pdop>

<extensions>

<gpxtpx:TrackPointExtension>

<gpxtpx:course>332.1</gpxtpx:course>

</gpxtpx:TrackPointExtension>

</extensions>

</trkpt>

<trkpt lat="54.437127" lon="10.179401">

<ele>6.55</ele>

<time>2018-07-24T16:13:12.000Z</time>

<pdop>4.00</pdop>

<extensions>

<gpxtpx:TrackPointExtension>

<gpxtpx:course>112.2</gpxtpx:course>

</gpxtpx:TrackPointExtension>

</extensions>

</trkpt>

photo
1

here's the log.....

photo
1

Hi Boris,

check your Locus settings > Track recording > select your recording profile settings > Record only when moving - is it switched on?

photo
1

I am experiencing a very similar problem: LM stops tracking ~10 minutes after my screen turns off. The selection of "Don't Optimize" is automatically changed to "Optimize"under Settings>Battery>Battery Optimization when LM is in use.

Device: OnePlus 5T with Android 8.1 / OxygenOS v.5.1.4

photo
1

Hi,

this "automatic update" of your battery optimization status is caused by your operation system and is not, unfortunately, in our power to influence it. Contact your device support or vendor.

photo
photo
1

same problem with HONOR 8 and ANDROID 8 since when installed android 8 no way to make my locus pro working properly have any idea how to get it as previously ?

photo
1

Hi,

in case of Honor/Huawei devices this way (or still is) caused by a faulty version of the device firmware, causing problems to all GPS-using applications. More info: http://help.locusmap.eu/topic/problem-with-locus-map-on-huawei-android-8-devices

photo
1

Hi,

if you install this app https://play.google.com/store/apps/details?id=eu.thedarken.wldonate

it works - someone posted this in the huawei thread... ;-)

photo
photo
1

Hej Michal,

hej all,


sorry for my late reply. Had my holidays....


First: Yes, my track-recording settings are 'distance and time' (1m / 10s), so the example during anchorage is obsolete.


I recorded some more tracks including this problem (attached) bat sadly, the logging LM-version seems to be overwritten by a automated update. So at the end there are only gpx fils - no logs.... ;-(


Boris

photo
1

Hi Boris,

uninstall your current version of Locus Map, install the "logging" version from the link below and disallow automatic updating of Locus in your Google Play. Then try to test more. Thanks!

Michal

photo
1

Hej Michal,

hej all,


again, I'm late.... But attached there is a gpx and some logs that hopefully show the matter.

Thanks,


Boris

photo
photo
1

Me again.....

here is another set of gpx and log files that show the issue.

Regards,

Boris

photo
1

Hi Boris,

the logs show only one thing - your device sends GPS position to Locus only once an hour. The reason for this behavior is completely unknown. We keep on digging.

photo
1

Hej Michal,

sorry for my delay again.....

To be honest I cannot follow your analysis! The gpx shows continous recording of trackpoints every some seconds until 16:25:59. Then it is interupted until 17:02:29.

How do you come to your opinion?

Regards,

Boris

<trkpt lat="54.379049" lon="10.179731">

<ele>4.55</ele>

<time>2018-09-18T16:26:59.000Z</time>

<pdop>4.00</pdop>

<extensions>

<gpxtpx:TrackPointExtension>

<gpxtpx:course>45.5</gpxtpx:course>

</gpxtpx:TrackPointExtension>

</extensions>

</trkpt>

<trkpt lat="54.421566" lon="10.183964">

<ele>5.55</ele>

<time>2018-09-18T17:02:29.000Z</time>

<pdop>4.00</pdop>

<extensions>

<gpxtpx:TrackPointExtension>

<gpxtpx:course>318.0</gpxtpx:course>

</gpxtpx:TrackPointExtension>

</extensions>

</trkpt>

photo
photo
1

My name is Uwe. I'm first time here.


Same promlem with interrups during tracking time.

Hardware: OnePlus 6 with Android 9 (Pie beta3), rooted.

Software/settings: LM pro, accu optimisation and intelligent accu OFF

I heared about the same problem with other tracking apps at:

https://www.android-hilfe.de/forum/original-firmwares-fuer-oneplus-6.3348/firmware-9-0-oxygenos-open-beta-3-pie.888607-page-5.html

May be a bug or problem only with Oreo or Pie ???

photo
1

Hi Uwe - I have the same problem with my OnePlus 5T - please go to the OnePlus 6 forum and describe your problem there. I have entered a note in the 5/5T forum, so maybe we can get OnePlus to look into it. Thanks! Rob

photo
photo
1

Hi Uwe,

a few weeks ago we were solving a similar issue on Huawei/Honor phones running Android 8. Issue was solved by releasing a new firmware for those phones. Maybe this time it's case of OnePlus... We know for sure that we can do nothing with it :(

Michal

photo
2

Hi together,


problem solved.

A "clean installation" of Android Pie 9.0 with removing userdata was the right way.

Now it works fine.

BR Uwe

photo
1

I'm a bit confused: Uwe did inject his problem into 'my' issue report (what is not a very good idea anyway). Now his stuff seems to be solved, but why is the whole thread marked as 'solved'? My issue still persists....

photo
1

Hi Boris,

your issue has most probably the same reason as Uwe's - system switching GPS off due to some kind of optimization. Nevertheless, you're right, your issue hasn't been solved yet. Marking it asn in progress again.

Michal

photo
1

Since December, 6, probably after Version 3.42 (5.12.2019+) was installed, I experience exactly the same problem. I already reported in the forum . Until now, I was not able to solve it.

I am using Locus Version 3.42.0 under Android 9 on a Samsung A50 (SM-A505FN Firmware: PPR1.180610.011.A505FNXXS2ASK1). It did work fine from Nov. 7 until Dec. 6 2019 ... apparently the day before Version 3.42 was installed on my device. After I noticed the problem for the first time, I used a Holux logger at the same time, which did log the track correctly.

photo
1

Hej Wilfried,

Merry Christmas!

Your statement is very interesting! I tended to make Samsung responsible for that issue but with your Holx experiment the situation view on the trouble seems to change!

Did you record the track simultanously with Locus an Holux?

Boris

photo
1

Thanks Boris. Merry Christmas, also to you!

Correct, after I first noticed this issue (Dec. 13), I made sure to always start the Holux GPSport 260 (a dedicated device - not a Smartphone app!) simultaneously with Locus track recording. Since that day all Locus tracks had gaps. However, sometimes it did work fine for more than an hour (for example yesterday - see attached screen shot), but at some point in time it stops and resumes after a while.

I verified all tracks recorded before Dec. 13 and found all was working fine before Dec. 7. Since Version 3.42 carries the date 5.12.2019+, I assume, on Dec. 7 I was using Locus 3.42 for the first time, whereas the (correct) track of Dec. 6 was recorded by a previous version of Locus.

In case it matters: Most of the times, I don't even open the Locus App, but start logging from the widget.

During the next days, I plan to try a different GPS logger on Android. If it shows similar problems, very likely Samsung is to blame - if it does not, it is Locus.

photo
2

Hi guys,

please monitor this site frequently: https://dontkillmyapp.com/samsung. It contains latest information on Samsungs measures regarding batter optimization causing defunct apps on background and also tips how to tackle the problems.

best regards

Michal, Locus team

photo
1

The suggestions on the Don't kill my app! site to "turn off Adaptive battery and Put apps to sleep" did not help, but I did try a different Android to log the track concurrently with Locus and it showed a very similar behavior. So most likely the problem is caused by Samsung.

photo
1

It seems, I found a workaround:

In Locus Settings -> Controlling Display -> Always screen on, I clicked Enable and then Specify -> When GPS is ON.

After I changing the setting this morning and starting track logging, Locus recorded it perfectly. On my way back, I purposely disabled Always screen on again and from that point on, the gaps re-appeared, like they did during the previous two weeks. Then I enabled Always screen on again, but switched off the display manually. The log did continue, but exactly 5 minutes later, it stopped again until I reached my destination, where it resumed logging - probably at the time when I opened my phone to finally end logging.

photo
1

Hi Wilfried,

your discovery just proves that the problem is in the Samsung system, killing background processes, i.e. processes, that don't engage the display. When the display is on, the system lets the app run.

Check twice you have all setup of your system done according to the "Dontkillmyapp" site.

best regards

Michal, Locus team

photo
1

Thanks Michal! Now it works, but so far, I only checked it at home for not longer than 90 minutes.

Already several days ago, I followed the recommendations of "Dontkillmyapp" (mainly according to the 4 item checklist) without any success. Only yesterday, I noticed this comment at the bottom of the page: "If you enable Edge Lighting for your app, then the app will not be able to wake up your screen. To allow your app to wake up your screen, please remove it from the Edge Lighting applications list."

As far as I can tell, "Edge Lighting" does not exist on my A50, but there is another new function called "Always On Display (AoD)" (@Boris: How about your A5?). After disabling AoD completely, the logging did not interrupt during a short 15 minutes test. AoD has several options to allow information to appear on the locked screen. I enabled AoD again, but without changing any of those options - and Locus still recorded the track for 15 minutes.

I believe, one combination of settings related to AoD caused the problem, but until now, I was not able to pinpoint, what exactly it was and I still need to record a track for a longer time.

photo
1

Unfortunately, I was too quick with above comment and realized later, the problem still exists. :(

photo
1

Well, the issue only touches me during the summertime (while sailing) and now it's the time again...!

I bought a Samsung Tab A 10.1 (2019). What a foolish idea, because I should know about the issue.....

Anyway, now i can tell it's the same with Android 9. ;-(

I wrote once more to the Samsung support and got the answer to ask at the Samsung Developer Community at developer.samsung.com/home.do . I will search their forum and ask there.

Boris

photo