Navigation voice commands no longer working

Stefano Franchi shared this question 2 years ago
Answered

I used to have navigation commands working through my bluetooth headset when following tracks imported from plotaroute.com. They no longer work. I tried several things:

- Created a route directly in LocusMap. Same negative result

- Turned bluetooth off - Same negative result

- Exported from plotaroute with different format instead of my usual .tcx. Negative

- Quit other sound application (e.g. TuneIn) when LocusMap is active. Negative

The problem does not seem to be with the route, because I do not get any sound at all, not even the customary "Let's go" when the track is started. Besides, I do see the navigation hints on the top left corner (the turn signs with the distance indication).

Suggestions strongly appreciated

Best Answer
photo

Settings:

1. Language and units > Text to speech > TTS engine ? com. google.android.tts ? TTS language (Ready to use) correct ?

Testphrase: Do you like Locus ? OK ?

2. Navigation Select Voice > Toggle between No Voice and Text to speech Testphrase OK at TTS select ?

3. @ Navigate > Tap Navigate (Big) Button > Mute Navigation Sound = Unset ? Volume Slider up ?

4. Miscellaneous > Audio Channel > Music Stream <=> Notification Stream (Test both) OK ?

Replies (4)

photo
1

Settings:

1. Language and units > Text to speech > TTS engine ? com. google.android.tts ? TTS language (Ready to use) correct ?

Testphrase: Do you like Locus ? OK ?

2. Navigation Select Voice > Toggle between No Voice and Text to speech Testphrase OK at TTS select ?

3. @ Navigate > Tap Navigate (Big) Button > Mute Navigation Sound = Unset ? Volume Slider up ?

4. Miscellaneous > Audio Channel > Music Stream <=> Notification Stream (Test both) OK ?

photo
1

Got it.


As I was going through the list, I was stuck at number 1 (Getting the TTS test phrase to be spoken out loud). Until I switched to a different language, got it working, and then switched back to English. I have no idea why this happened, but not it works.

Point 2 and 4 I had already tested previously (forgot to mention that in my previous message).

Point 3 I don't quite understand. Where is the Navigate menu? In the track panel for the selected track I can choose navigation, but there is no such thing as "Mute Navigation Sound." Is it one of the settings? If so, i could not find it.

At any rate, the issue can be marked as SOLVED.


Thanks for the help

photo
1

Point 3: @ activated so operational Navigate screen you find the Big Direction Indicator_Button in the left top corner. Tap this indicator button and find "Mute navigation sounds" and a volume glider. Roger ?

photo
1

Yep, that where it is...I never thought the big arrow was a button!

photo
1

Hello Stefano.

Did you found settings of navigation sounds?

Thank you @0709 for support.

Best regards.

Adela Voldanova

photo
1

Yep, I found everything, now it works as it used to.

photo
photo
1

Hello everybody,

as a very satisfied user of locus for years I recently discovered the following problem:

since some weeks the voice output from the navigation is not working anymore. To be more precise it works with a custom voice (called Karin in German) but not with the google tts standard.

Seems to be a communication problem between locus and the google interface. After deleting the voice from my phone and reinstalling the tts files, it worked for one time. But after the first navigation command it somehow crashes, and there is no more voice output.


The test phrase in locus works with some other languages (english, spanish and some others) but not with the german languages.

Could this be a locus issue ?


King regards


Manfred

Leave a Comment
 
Attach a file